自拍偷在线精品自拍偷,亚洲欧美中文日韩v在线观看不卡

不連續(xù)網絡配置及其解決方案

企業(yè)動態(tài)
不連續(xù)網絡配置及其解決方案。
 
配置RIPV1
R1基本配置
    Router>enable
Router#conf t
Router(config)#host r1
R1(config)#int s2/1
R1(config-if)#ip add 12.1.1.1 255.255.255.0
R1(config-if)#no shut
R1(config-if)#exit
R1(config)#int f0/0
R1(config)#ip add 172.16.10.1 255.255.255.0
R1(config)#no shut

R2基本配置
    Router>enable
Router#conf t
Router(config)#int s2/1
Router(config-if)#ip add 12.1.1.2 255.255.255.0
Router(config-if)#no shut
Router(config-if)#exit
Router(config)#int f0/0
Router(config-if)#ip add 172.16.20.1 255.255.255.0
Router(config-if)#no shut

配置RIPV1
R1配置rip
   R1(config)#router rip
R1(config-route)#net 12.0.0.0
R1(config-route)#net 172.16.10.0

R2配置rip
    R2(config)#router rip
R2(config-route)#net 12.0.0.0
R2(config-route)#net 172.16.20.0

檢測網絡
  R1#ping 172.16.20.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.20.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/1)
R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
   D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
   N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
   E1 - OSPF external type 1, E2 - OSPF external type 2
   i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
  ia - IS-IS inter area, * - candidate default, U - per-user static route
  o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.10.0 is directly connected, FastEthernet0/0
     12.0.0.0/24 is subnetted, 1 subnets
C       12.1.1.0 is directly connected, Serial2/1
r2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
  D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
  N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
  E1 - OSPF external type 1, E2 - OSPF external type 2
  i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
  ia - IS-IS inter area, * - candidate default, U - per-user static route
  o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.20.0 is directly connected, FastEthernet0/0
     12.0.0.0/24 is subnetted, 1 subnets
C       12.1.1.0 is directly connected, Serial2/1
r2#show ip pro
Routing Protocol is "rip"
  Sending updates every 30 seconds, next due in 1 seconds
  Invalid after 180 seconds, hold down 180, flushed after 240
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Redistributing: rip
  Default version control: send version 1, receive any version
    Interface           Send  Recv  Triggered RIP  Key-chain
    FastEthernet0/0       1     1 2                                 
    Serial2/1             1     1 2                                 
  Automatic network summarization is in effect
  Maximum path: 4
  Routing for Networks:
    12.0.0.0
    172.16.0.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    12.1.1.1             120      00:00:24
  Distance: (default is 120)
這就是不連續(xù)網絡造成的下來我們用不同方法來解決,讓它可以ping通。
方法1 配置ripv2
      借助ripv2的特性支持不連續(xù)網絡,支持可變長子網
  R1(config)#router rip
R1(config-router)#version 2
R2(config)#router rip
R2(config-router)#version 2
r1#show ip pro    //注意查看變化
Routing Protocol is "rip"
  Sending updates every 30 seconds, next due in 15 seconds
  Invalid after 180 seconds, hold down 180, flushed after 240
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Redistributing: rip
  Default version control: send version 2, receive version 2
    Interface           Send  Recv  Triggered RIP  Key-chain
    FastEthernet0/0       2     2                                   
    Serial2/1             2     2                                   
  Automatic network summarization is in effect
  Maximum path: 4
  Routing for Networks:
    12.0.0.0
    172.16.0.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    12.1.1.2             120      00:00:02
  Distance: (default is 120)
r2#show ip pro
Routing Protocol is "rip"
  Sending updates every 30 seconds, next due in 10 seconds
  Invalid after 180 seconds, hold down 180, flushed after 240
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Redistributing: rip
  Default version control: send version 2, receive version 2
    Interface           Send  Recv  Triggered RIP  Key-chain
    FastEthernet0/0       2     2                                   
    Serial2/1             2     2                                   
  Automatic network summarization is in effect
  Maximum path: 4
  Routing for Networks:
    12.0.0.0
    172.16.0.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    12.1.1.1             120      00:00:00
  Distance: (default is 120)


#p#

檢測網絡通斷

   r1#ping 172.16.20.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.20.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/114/196 ms
r2#ping 172.16.10.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.10.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 24/108/200 ms

我們發(fā)現(xiàn)網絡通了。這就是RIPV1與RIPV2的特征不同所決定的
方法2配置靜態(tài)路由
靜態(tài)路由的管理距離為默認為1.而rip的管理距離為120。所以在這個時候是靜態(tài)路由起作用所以路由由不通到通
在配置完RIP后,我們再來配置兩條靜態(tài)路由
    r1(config)#ip route 172.16.20.0 255.255.255.0 12.1.1.2
R2(config)#ip route 172.16.10.0 255.255.255.0 12.1.1.1
 
r1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * -  candidate defa ult, U - per-user static route
 o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
     172.16.0.0/24 is subnetted, 2 subnets
S       172.16.20.0 [1/0] via 12.1.1.2
C       172.16.10.0 is directly connected, FastEthernet0/0
     12.0.0.0/24 is subnetted, 1 subnets
C       12.1.1.0 is directly connected, Serial2/1
方法三在每個接口上通告發(fā)送數(shù)據(jù)用RIPV2
R1配置
    R1#config t
R1(conf ig)#router rip
R1(conf ig- router)#net 12.0.0.0
R1(conf ig- router)#net 172.16.10.0
R1(config-router)#int s2/1
R1(config-if)#ip rip send version 2
R1(config-if)#int f0/0
R1(config-if)#ip rip send version 2
R2配置
   R2#config t
R2(conf ig)#router rip
R2(conf ig- router)#net 12.0.0.0
R2(conf ig- router)#net 172.16.20.0
R2(config-router)#int s2/1
R2(config-if)#ip rip send version 2
R2(config-if)#int f0/0
R2(config-if)#ip rip send version 2

測試網絡
   R1#Ping 172.16.20.1 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.20.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/109/208 ms
r1#show ip pro
Routing Protocol is "rip"
  Sending updates every 30 seconds, next due in 22 seconds
  Invalid after 180 seconds, hold down 180, flushed after 240
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Redistributing: rip
  Default version control: send version 1, receive any version
    Interface             Send  Recv  Triggered RIP  Key-chain
    FastEthernet0/0       2     1 2                                 
    Serial2/1             2     1 2                                 
  Automatic network summarization is in effect
  Maximum path: 4
  Routing for Networks:
    12.0.0.0
    172.16.0.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    12.0.0.2             120      00:00:10
  Distance: (default is 120)

大家對照第四頁和第六頁的紅字部分看看他們的區(qū)別
方法四,在同一接口上配置雙IP來解決
我們在有RIPv1運行的情況下來進行配置
我們在中間網絡中配置雙IP   即R1 和R2上的S2/1上
我們給他配上172.16.30.0這個網絡
    R1(config)#int s2/1
R1(config-if)#ip add 172.16.30.1 255.255.255.0 secondary
R2(config)#int s2/1
R2(config-if)#ip add 172.16.30.2 255.255.255.0 secondary
R2#  show run int s2/1
Building configuration...
Current configuration : 134 bytes
!
interface Serial2/1
 ip address 172.16.30.2 255.255.255.0 secondary
 ip address 12.0.0.2 255.255.255.0
 serial restart-delay 0
end
R1#  show run int s2/1
Building configuration...
Current configuration : 134 bytes
!
interface Serial2/1
 ip address 172.16.30.1 255.255.255.0 secondary
 ip address 12.0.0.1 255.255.255.0
 serial restart-delay 0
end
我們來測試以下網絡
R1#Ping 172.16.20.1        //大家可以自己去試一試

【編輯推薦】

  1. IPV6的配置實例
  2. 北京某大型網吧Cisco 3700系列路由器優(yōu)化方案
  3. 五個你從未用過的路由器與交換機功能
責任編輯:夏雨 來源: 56CTO.com
相關推薦

2022-02-23 12:07:20

分布式Spark數(shù)據(jù)傾斜

2022-03-18 15:31:19

物聯(lián)網IOT

2011-02-15 13:21:17

業(yè)務連續(xù)性安全威脅

2010-09-09 10:29:47

2020-08-25 07:00:00

云計算云安全數(shù)據(jù)

2020-06-08 22:33:42

物聯(lián)網IOT物聯(lián)網實施

2010-12-24 12:49:39

2012-07-31 14:30:26

ReadyNAS解決方案

2022-11-21 17:46:09

2024-06-21 08:04:48

2009-10-27 15:35:08

2013-09-16 09:07:15

網絡配置備份NCM

2023-11-03 19:52:43

大數(shù)據(jù)

2024-06-12 12:59:16

2010-02-24 09:28:37

WCF安全配置

2011-06-20 13:24:11

網站快照

2019-05-10 15:36:25

物聯(lián)網IOT技術

2010-10-20 16:01:29

網絡管理解決方案網絡管理

2011-08-09 17:30:48

2011-10-14 10:37:47

虛擬機 負載
點贊
收藏

51CTO技術棧公眾號