基于IOS和CLI的交換機的基礎(chǔ)配置命令
1.在基于IOS的交換機上設(shè)置主機名/系統(tǒng)名:
switch(config)# hostname hostname
在基于CLI的交換機上設(shè)置主機名/系統(tǒng)名:
switch(enable) set system name name-string
2.在基于IOS的交換機上設(shè)置登錄口令:
switch(config)# enable password level 1 password
在基于CLI的交換機上設(shè)置登錄口令:
- switch(enable) set password
- switch(enable) set enalbepass
3.在基于IOS的交換機上設(shè)置遠程訪問:
- switch(config)# interface vlan 1
- switch(config-if)# ip address ip-address netmask
- switch(config-if)# ip default-gateway ip-address
在基于CLI的交換機上設(shè)置遠程訪問:
- switch(enable) set interface sc0 ip-address netmask broadcast-address
- switch(enable) set interface sc0 vlan
- switch(enable) set ip route default gateway
4.在基于IOS的交換機上啟用和瀏覽CDP信息:
- switch(config-if)# cdp enable
- switch(config-if)# no cdp enable
為了查看Cisco鄰接設(shè)備的CDP通告信息:
- switch# show cdp interface [type modle/port]
- switch# show cdp neighbors [type module/port] [detail]
在基于CLI的交換機上啟用和瀏覽CDP信息:
switch(enable) set cdp {enable|disable} module/port
為了查看Cisco鄰接設(shè)備的CDP通告信息:
switch(enable)show cdp neighbors[module/port] [vlan|duplex|capabilities|detail]
5.基于IOS的交換機的端口描述:
switch(config-if)# description description-string
基于CLI的交換機的端口描述:
switch(enable)set port name module/number description-string
6.在基于IOS的交換機上設(shè)置端口速度:
switch(config-if)# speed{10|100|auto}
在基于CLI的交換機上設(shè)置端口速度:
- switch(enable) set port speed moudle/number {10|100|auto}
- switch(enable) set port speed moudle/number {4|16|auto}
7.在基于IOS的交換機上設(shè)置以太網(wǎng)的鏈路模式:
switch(config-if)# duplex {auto|full|half}
在基于CLI的交換機上設(shè)置以太網(wǎng)的鏈路模式:
switch(enable) set port duplex module/number {full|half}
8.在基于IOS的交換機上配置靜態(tài)VLAN:
- switch# vlan database
- switch(vlan)# vlan vlan-num name vla
- switch(vlan)# exit
- switch# configure teriminal
- switch(config)# interface interface module/number
- switch(config-if)# switchport mode access
- switch(config-if)# switchport access vlan vlan-num
- switch(config-if)# end
在基于CLI的交換機上配置靜態(tài)VLAN:
- switch(enable) set vlan vlan-num [name name]
- switch(enable) set vlan vlan-num mod-num/port-list
9. 在基于IOS的交換機上配置VLAN中繼線:
- switch(config)# interface interface mod/port
- switch(config-if)# switchport mode trunk
- switch(config-if)# switchport trunk encapsulation {isl|dotlq}
- switch(config-if)# switchport trunk allowed vlan remove vlan-list
- switch(config-if)# switchport trunk allowed vlan add vlan-list
在基于CLI的交換機上配置VLAN中繼線:
- switch(enable) set trunk module/port [on|off|desirable|auto|nonegotiate]
- Vlan-range [isl|dotlq|dotl0|lane|negotiate]
10.在基于IOS的交換機上配置VTP管理域:
- switch# vlan database
- switch(vlan)# vtp domain domain-name
在基于CLI的交換機上配置VTP管理域:
switch(enable) set vtp [domain domain-name]
11.在基于IOS的交換機上配置VTP 模式:
- switch# vlan database
- switch(vlan)# vtp domain domain-name
- switch(vlan)# vtp {sever|cilent|transparent}
- switch(vlan)# vtp password password
在基于CLI的交換機上配置VTP 模式:
switch(enable) set vtp [domain domain-name] [mode{ sever|cilent|transparent }][password password]
12. 在基于IOS的交換機上配置VTP版本:
- switch# vlan database
- switch(vlan)# vtp v2-mode
在基于CLI的交換機上配置VTP版本:
switch(enable) set vtp v2 enable
13. 在基于IOS的交換機上啟動VTP剪裁:
- switch# vlan database
- switch(vlan)# vtp pruning
在基于CL I 的交換機上啟動VTP剪裁:
switch(enable) set vtp pruning enable
14.在基于IOS的交換機上配置以太信道:
switch(config-if)# port group group-number [distribution {source|destination}]
在基于CLI的交換機上配置以太信道:
switch(enable) set port channel moudle/port-range mode{on|off|desirable|auto}
15.在基于IOS的交換機上調(diào)整根路徑成本:
switch(config-if)# spanning-tree [vlan vlan-list] cost cost
在基于CLI的交換機上調(diào)整根路徑成本:
- switch(enable) set spantree portcost moudle/port cost
- switch(enable) set spantree portvlancost moudle/port [cost cost][vlan-list]
16.在基于IOS的交換機上調(diào)整端口ID:
switch(config-if)# spanning-tree[vlan vlan-list]port-priority port-priority
在基于CLI的交換機上調(diào)整端口ID:
- switch(enable) set spantree portpri {mldule/port}priority
- switch(enable) set spantree portvlanpri {module/port}priority [vlans]
17. 在基于IOS的交換機上修改STP時鐘:
- switch(config)# spanning-tree [vlan vlan-list] hello-time seconds
- switch(config)# spanning-tree [vlan vlan-list] forward-time seconds
- ` switch(config)# spanning-tree [vlan vlan-list] max-age seconds
在基于CLI的交換機上修改STP時鐘:
- switch(enable) set spantree hello interval[vlan]
- switch(enable) set spantree fwddelay delay [vlan]
- switch(enable) set spantree maxage agingtiame[vlan]
18. 在基于IOS的交換機端口上啟用或禁用Port Fast 特征:
switch(config-if)#spanning-tree portfast
在基于CLI的交換機端口上啟用或禁用Port Fast 特征:
switch(enable) set spantree portfast {module/port}{enable|disable}
19. 在基于IOS的交換機端口上啟用或禁用UplinkFast 特征:
switch(config)# spanning-tree uplinkfast [max-update-rate pkts-per-second]
在基于CLI的交換機端口上啟用或禁用UplinkFast 特征:
switch(enable) set spantree uplinkfast {enable|disable}[rate update-rate] [all-protocols off|on]
基于IOS的交換機和基于CLI的交換機的基礎(chǔ)配置命令就為大家呈現(xiàn)這么多,希望讀者能夠掌握和利用。
【編輯推薦】